I’m on Windows 10, with Node 5.6.0 and npm 3.6.0. I’m trying to install angular-material and mdi into my working folder. npm install angular-material mdi errors with:
+-- [email protected] +-- UNMET PEER DEPENDENCY [email protected]^1.5.0 +-- UNMET PEER DEPENDENCY [email protected]^1.5.0 +-- [email protected] +-- UNMET PEER DEPENDENCY [email protected]^1.5.0 `-- [email protected] npm WARN enoent ENOENT: no such file or directory, open 'C:UsersxxxxxDesktopngClassifiedspackage.json' npm WARN [email protected] requires a peer of [email protected]^1.5.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]^1.5.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]^1.5.0 but none was installed.
How do I resolve this to get AngularJS Material and MDI installed?
Below are the methods you can try. The first solution is probably the best. Try others if the first one doesn’t work. Senior developers aren’t just copying/pasting – they read the methods carefully & apply them wisely to each case.
npm no longer installs peer dependencies so you need to install them manually, just do an
npm install on the needed deps, and then try to install the main one again.
Reply to comment:
it’s right in that message, it says which deps you’re missing
UNMET PEER DEPENDENCY [email protected]^1.5.0 +-- UNMET PEER DEPENDENCY [email protected]^1.5.0 +-- [email protected] + UNMET PEER DEPENDENCY [email protected]^1.5.0 `-- [email protected]`
So you need to
npm install angular angular-animate angular-aria angular-material angular-messages mdi
UNMET PEER DEPENDENCY error is thrown when the dependencies of one or more modules specified in the
package.json file is not met.
Check the warnings carefully and update the
package.json file with correct versions of dependencies.
rm -rf node_modules/ npm cache clean npm install
This will install all the required dependencies correctly.
In my case all the dependencies were already there. Please update NPM in that case as it might have been crashed. It solved my problem.
npm install -g npm
From npm v7.0.0, npm automatically installs peer dependencies. It is one of the reasons to upgrade to v7.
Also this page explains the rationale of peer dependencies very well.
This answer doesn’t apply all cases, but if you can’t solve the error by simply typing
, this steps might help.
Let`s say you got this error.
UNMET PEER DEPENDENCY [email protected] npm WARN [email protected] requires a peer of [email protected]^3.1.0 but none was installed.
So you can resolve this error by downgrading packageA to 3.x.x, but usually you don`t want to downgrade the package.
Good news is that in some cases, packageB is just not keeping up with packageA and maintainer of packageB is trying hard to raise the peer dependency of packageA to 4.x.x.
In that case, you can check if there is a higher version of packageB that requires version 4.2.0 of packageA in the npm or github.
Oftentimes you can find breaking change about dependency like this.
packageB v4.0.0-beta.0 BREAKING CHANGE package: requires packageA >= v4.0.0
If you don’t find anything on release page, go to issue page and search issue by keyword like
peer. You may find useful information.
At this point, you have two options.
- Upgrade to the version you want
- Leave error for the time being, wait until stable version is released.
If you choose option1:
In many cases, the version does not have
latest tag thus not stable. So you have to check what has changed in this update and make sure anything won`t break.
If you choose option2:
If upgrade of pakageA from version 3 to 4 is trivial, or if maintainer of pakageB didn’t test version 4 of pakageA yet but says it should be no problem, you may consider leaving the error.
In both case, it is best to thoroughly test if it does not break anything.
Lastly, if you wanna know why you have to manually do such a thing, this link explains well.
npm-install-peers worked for me.
npm install -g npm-install-peers
One of the most possible causes of this error could be that you have defined older version in your package.json. To solve this problem, change the versions in the package.json to match those npm is complaining about.
Once done, run npm install and voila!!.
The given answer wont always work. If it does not fix your issue. Make sure that you are also using the correct symbol in your
package.json. This is very important to fix that headache. For example:
warning " > @angular/[email protected]" has incorrect peer dependency "[email protected]>=2.4.2 <2.7". warning " > [email protected]" has incorrect peer dependency "[email protected]>=2.4.2 <2.6".
So my typescript needs to be between 2.4.2 and 2.6 right?
So I changed my typescript library from using
"typescript": "^2.7" to using
"typescript": "^2.5". Seems correct?
^ means that you are okay with npm using
"typescript": "2.5" or
If you want to learn what the
~ it mean see: What’s the difference between tilde(~) and caret(^) in package.json?
Also you have to make sure that the package exists. Maybe there is no
"typescript": "2.5.9" look up the package numbers. To be really safe just remove the
~ or the
^ if you dont want to read what they mean.
Ok so i struggled for a long time trying to figure this out. Here is the nuclear option, for when you have exhausted all other ways..
- Make a new folder on your pc.
- Download a brand new installation of angular – I used this guide: https://coursetro.com/posts/code/55/How-to-Install-an-Angular-4-App
- Run it, make sure it works
- Then install your dependancies one by one from your package.json file
- Run it after each one is installed
When you are done, and it still works, import your actual code into this new project. Fix any compile errors the newer version of angular causes.
Thats what did it for me.. 1 hour of rework vs 6 hours of trying to figure out wtf was wrong.. wish i did it this way to start..
Today available Angular 2 rc.7, and I had a similar problem with
[email protected] UNMET PEER DEPENDENCY.
If you, like me, simply replaced
@angular/...rc.7 – it’s not enough. Because, for example,
@angular/router has no
In this case, better review package.json in Quick start
You will get this warning if you are using npm v6 or before. After npm v7.0, npm development team has stated that they will automatically install peer dependencies, all together. Therefore, now you don’t want to install your peer dependencies manually.
You can install npm v7.0 using this command,
npm install -g [email protected]
Learn more about npm v7.0 from this blog post, published by the Github Blog.
This issue can also occur when trying to fix a security vulnerability issue on a dependency.
Here is what I did:
Audited installed dependencies
If there are fix available, running the following would fix the issue most of the time:
npm audit fix
Some issues would have SEMVER WARNING, following the link would give us hint on how to do a manual review and/or what to do next.
Doing a bit more research led me to discovering this command:
npm audit fix did not account on updating peer dependencies, and running
npm upgrade would fixed unmet peer dependencies.
Now check if we resolved the issue by running:
This will give us all dependencies for our project and warn us of any unmet peer deps errors. Upgrading for the most part is actually better than staying on older version of the package you are using, if you are not having a security vulnerability issue
npm install is also a viable option.
In case you wish to keep the current version of angular, you can visit this version compatibility checker to check which version of angular-material is best for your current angular version. You can also check peer dependencies of angular-material using angular-material compatibility.
you can resolve by installing the UNMET dependencies globally.
example : npm install -g @angular/[email protected]
install each one by one.
its worked for me.