Bad class file magic or version

The question:

I already know that question has been already asked very often and answers, but no one of the answers i found fixed my problem.

It’s the error:

Error:Gradle: Execution failed for task ':ffcommunity:preDexDebug'. Failed to run command:
    D:Android SDKsdkbuild-tools20.0.0dx.bat --dex --output D:UsersReVoDocumentsIntelliJ IDEAFFCommunityffcommunitybuildintermediatespre-dexeddebugbananaquery-2ee85432877a057e7414910b8127805535139d5d.jar D:UsersReVoDocumentsIntelliJ IDEAFFCommunityffcommunitylibsbananaquery.jar
Error Code:
    UNEXPECTED TOP-LEVEL EXCEPTION: bad class file magic (cafebabe) or version (0034.0000)
    ...while parsing com/comuf/revonline/bananaquery/BananaInsert.class
    1 error; aborting

The error is bad class file magic (cafebabe) or version (0034.0000).

I builded and execute the application without problems many times in the same day but now this fails everytime with this message.

Project SDK is Android API 19 Platform and project level is 1.7.

CompileSDK is 19 and buildToolsVersion is '20.0.0'.

Compile options:

compileOptions {
    sourceCompatibility JavaVersion.VERSION_1_7
    targetCompatibility JavaVersion.VERSION_1_7

and in dependencies i have:

compile files('libs/bananaquery.jar')

The library is build with SDK Android API 19 Platform with project level 1.7.

My .jar file is inside libs/ folder.

I use IntelliJ IDEA 14 Preview, it could be the reason? With IntellIJ IDEA 13 it remains stuck at “Gradle sync”

compile files could be useless since i have compile fileTree(dir: 'libs', include: ['*.jar']) too

The Solutions:

Below are the methods you can try. The first solution is probably the best. Try others if the first one doesn’t work. Senior developers aren’t just copying/pasting – they read the methods carefully & apply them wisely to each case.

Method 1

my JAVA_HOME variable changed to Java 1.8 and I got this error message when compiling a pure java module as a dependency of my android project.

build.gradle of the java module

apply plugin: 'java'

Solution #1: Quick an dirty

I fixed it by setting my JAVA_HOME back to 1.7:

export JAVA_HOME=`/usr/libexec/java_home -v 1.7`

Solution #2: change compiler version:

change back to 1.7 for this specific module in its build.gradle

apply plugin: 'java'
sourceCompatibility = 1.7
targetCompatibility = 1.7

Method 2

Ok, my bad.

In the Project SDK section, when you add an Android SDK you should provide the Java SDK and all my Android SDKs uses Java 8 as SDK so it create the class files with the wrong version even if the Project level is 1.7 (i don’t know why, i supposed that everything was choosed by Project level).

Now i changed the SDK (the java version "1.x.0" part.)

enter image description here

and it seems to compile fine.

The reason that worked before today was because my SDK was 1.8 and not Android API x

Method 3

In case people find @Marco Acierno’s answer to be a bit unclear, the solution is to ensure you’re building with Java 7 and not a higher version.

For Android Studio, change File -> Project Structure -> SDK Location -> JDK Location to jdk1.7.x. For the command line, ensure java -version outputs java version "1.7.x".

Method 4

Setting JAVA_HOME back to 1.7 worked for me.

Method 5

change all your module java version to java 1.7 in every build.grade file.

in plugin which is library and application


and in java

sourceCompatibility= 1.7
targetCompatibility= 1.7

Method 6

This problem occurs when you use a .jar file that is not using any feature of Java 6 or higher but was built using Java 6 or higher.

If you built that .jar file then you don’t need to change anything in Gradle or ProGuardor Compiler Version. The solution is very simple, just build that .jar file again but using Java 5 or less.

More details.

Method 7

I had a similar issue, i solved it by upgrading my proguard.
get your proguard version by this command

java -jar ~/android-sdks/tools/proguard/lib/proguard.jar 

get the latest progaurd.jar file from here (

replace the existing android-sdks/tools/proguard/lib/proguard.jar with new .jar file.

Hopefully this should help you.
If u using java 8 then you should upgrade to proguard 5.x coz proguard 4.x does not support java 8.

Method 8

had a similar issue when i tried to add a self made library from netbeans to android studio. setting the source- and target compatibility in android studio and source/binary format in netbeans (both!) to java 1.7 solved the problem.

in android studio:

Project Structure -> Modules/App -> Propreties -> Source- and Target to 1.7

in netbeans:

File -> Project Properties -> Sources -> Source/Binary Format to 1.7

then clean and build your netbeans projekt and copy the .jar from “NBProj/dist” to “app/libs”

Method 9

share the solution of the case if only Java8 installed, just set Java compiler level to 1.7 and then rebuild the project should be OK.

Method 10

I got the error when using a third party library. In accordance with the above-mentioned question, it was necessary to replace the library according to the above stack trace message:

    ...while parsing com/comuf/revonline/bananaquery/BananaInsert.class

with the appropriate version.

Corresponding to the question, bananaquery.jar is to be replaced by the Java-compatible version.

All methods was sourced from or, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Comment